Jump to content
Atuteth

PCB multirom maison et Multigame maker

Recommended Posts

Salut a tous !

 

Dans un premier temps bonne année , ensuite je ne sais pas trop ou poser mon sujet vue que je n'est pas accès a d'autre section de ce super forum qui transpire de compétence dans la modif...

 

Desolé c'est surement pas au bon endroit , un modo pourra surement deplacer le sujet ou me donner des accès au autre sections j'espère.

 

voila mon problème:

je suis partie sur une PCB Multigame maison avec un 74hct74n pour activer une des 4 bank d'une Rom MD sur une eprom 27c322 

toutes mes soudure son bonnes , j'ai bien une bascule  sur A20 et  A19 a chaque reset (vérifié a la sonde logique)

A20  A19  

  0       0         mise en route/4eme reset
  0       1         1er reset
  1       0         2eme reset
  1       1         3eme reset

 

je prépare ma rom avec le prog de X-death en config 4x1Mo , je prend 4 rom ,  j'obtiens une rom de 4Mo, je fais un bitswap et je burn dans une 27c322 ... jusque la tout va bien ! 

cela ne marche pas après...  j'obtiens que les 2 première rom , je n'arrive pas a avoir la rom 3 et 4 !

marche rom1 

1er reset  rom2 

2nd reset rom1 avec bug

3eme reset rom2 avec bug

4eme reset rom1 .....

 

et la je sèche ... avez vous une idée d'ou peu venir le problème ?

 

Merci 

Manu

 

 

Share this post


Link to post
Share on other sites

Super projet.

Le patron du forum (Ichigo) a deja realiser un PCB similaire. Il permet de réaliser un jeu ou une compil' de jeux sur SEGA Megadrive. Les fichiers sont disponible sur le forum.

Mais je ne pense pas que cette section te soit déjâ accessible...

Néanmoins il est la personne la plus apte à t'aider là dessus ;-p

Share this post


Link to post
Share on other sites
Il y a 21 heures, yolt1 a dit :

Super projet.

Le patron du forum (Ichigo) a deja realiser un PCB similaire. Il permet de réaliser un jeu ou une compil' de jeux sur SEGA Megadrive. Les fichiers sont disponible sur le forum.

Mais je ne pense pas que cette section te soit déjâ accessible...

Néanmoins il est la personne la plus apte à t'aider là dessus ;-p

Merci pour l'accueil , c'est en contactant X-death pour sont prog qu'il ma dit de venir poster mon problème... je connais a peu près les travaux de Ichigo qui sont énorme pour la communauté mais pour l'instant j'avance pas ... vivement les 10 messages hihi 

Il y a 4 heures, Redfield1 a dit :

Sois le bienvenu.

merci pour l'accueil

Share this post


Link to post
Share on other sites
Il y a 3 heures, Atuteth a dit :

salut je suis limité a 3 message par jour pas evident de repondre ainsi (peu etre un bug ?) , donc pour resumer

power on ---> TMSS ---> ROM1 

1er reset ---> ROM2 

2eme reset ----> retour sur ROM1 bugg pas de son et/ou defaut de sprite

3eme reset ----> ROM2  bugg pas de son et/ou defaut de sprite

4eme reset ----> ROM1 sans bug ....ect

Donc déjà tu as un soucis de câblage , et surement une adresse flottante ou un problème du à l'utilisation du reset soft et pas du hard reset.

il faudrait que tu partage le schéma de ta cartouche , notamment le câblage du 74HCT74.

P.S : +1 pour virer la restriction sur le nombre de message

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...