Jump to content
Bool

[Besoin d'aide] Remplacement Maskroms HS - Final Lap Namco System 2

Recommended Posts

Bonsoir à tous,

 

Un ami faisant dans l'arcade m'a demandé de l'aider pour remplacer deux maskroms qu'il a identifié comme defectueuses sur une de ses cartes Final Lap sur Namco System 2.

 

Il a deux cartes identiques, donc a pu déterminer en inversant les maskroms lesquelles posaient problème (des glitchs graphiques dans le jeu).

 

Les défectueuses sont CHR-0 et CHR-7 référencées 23C401, voir schéma joint.

 

Il faudrait donc que je puisse lui programmer deux eproms équivalentes à celles défectueuses, pour cela il faut trouver une eprom compatible.

 

J'ai regardé les pinouts et me suis tourné vers les 27C4001 (je me trompe peut être grossièrement, n'hésitez pas a me corriger) mais il y a cependant quelques différences :

 

-Sur la 27c4001 la pin 22 = /E et la pin 24 = /G alors que sur la maskrom 23c401 la pin 22 = CE et la pin 24 = OE

 

Mes connaissances ne me permettent pas de déterminer si ces eproms correspondraient ou non...

De plus j'ai essayé de regarder les datasheets mais je suis pas sûr d'avoir tout compris, hormis les pinouts presque semblables.

 

Voici ce que j'ai en ma possession pour essayer de résoudre le problème :

-Un GQ4X

-Les deux maskroms CHR-0 et CHR-7 défectueuses,

-Deux maskroms CHR-0 et CHR-7 qui fonctionnent

-Les fichiers à programmer sur les futurs eproms, d'ailleurs j'ai comparé le fichier de CHR-0 avec la CHR-0 fonctionnelle en l'ayant lue comme si c'était une 27c4001 avec mon GQ4X, ça correspond hormis que le fichier lu fait 512kb et que le fichier de base fait 256kb... ça me fait penser à l'expand de rom que l'on fait parfois sur snes.

 

Voici aussi une précision du possesseur de la carte :

"Pour information sur le pinout, sur le schémas seul le JP88 est dans la bonne position, les 3 autres sont dans l'autre position sur mes PCB."

 

Je vous joint le schéma,

Merci d'avance pour l'attention que vous porterez à mon message,

J'aimerais réussir à résoudre ce problème en comprenant ce que je fais, et pas en y allant à tâtons...

 

A+,

 

Bool.

post-6158-0-96454600-1471895492_thumb.jpg

Share this post


Link to post
Share on other sites

Lo,

 

J'ai pas trop le temps de regarder ce soir, j'ai d'ailleurs même survolé Ron post :/

Mais de tête avec deux ou trois redirections, tu peux te servir de sst en sample MC.

Pense à foutre deux tulipes aussi, ça t'évitera de désouder si c'est pas bon.

Share this post


Link to post
Share on other sites

Déjà :

/CE et /E c'est pareil

/OE et /G, c'est pareil aussi.

La dénomination change parfois avec le fabricant.

 

pour le pinout c'est bien une bête 27c4001 / 27C040.

 

si les roms que tu as recup font 256k, double les pour faire 512k.

car le jp88 va forcer la lecture à partir de la seconde moitié de l'eprom (vu que A18 est relié à vcc)

Share this post


Link to post
Share on other sites

Salut Ichigo,

 

C'est ce dont je viens de me rendre compte en comparant les pinouts d'une MX27C4000 et de la 27c4001,

 

Donc a prioris il n'y aura aucune redirection à faire...

 

Donc en théorie je devrais juste expand mon fichier de 256kb par 256kb de vide pour remplir les 512kb de la 27c4001?

 

Ou plus simple ecrire les fichiers dumpés des 23c401 valides dans mes deux 27c4001 vierges

 

Merci beaucoup

Share this post


Link to post
Share on other sites

Tout est dit par le chef.

Quand je disais sst, je parlais des simples qu'on peut avoir gratos chez microchip, ça t'évitais d'investir si tu n'avais pas les eproms.

 

Edit : tu as posté entre temps.

Donc non, tu vas lire la partie haute de l'eprom. Donc si tu combles avec du vide, tu vas lire du vide.

Faut la doubler :

Sous Windows : copy /b ficher + fichier fichier_double

Ou avec join/cat sous Linux

Share this post


Link to post
Share on other sites

De nouveau merci pour ta réponse,

 

J'ai commande des 27c4001 sur ali-misère, je ne sais pas comment faire pour le moment pour les avoir gratos chez microchip, 8€ les 10...

 

Comment as tu déterminer que la carte lira la partie haute de l'eprom?

Edit : je viens de voir la fin du message d'Ichigo, ok j'ai pigé.

 

Ce qui est étonnant c'est que je viens de voir que les 23c401 sont bien des eproms 4MB et le fichier qu'on a est un 256kb, je sais pas ou mon pote l'a récupéré parcontre...

 

Quoi qu'il en soit avec vos réponse je devrais y arriver :smile:

Share this post


Link to post
Share on other sites

Et si là tu y arrives pas...

Tu passes une semaine chez Will :D

Enfin physiquement c'est plutôt Will qui va passer une semaine chez toi... Et il passe toujours par la porte de derrière.

Share this post


Link to post
Share on other sites

Haha, à travers les lectures de divers topic du forum j'ai cru comprendre qu'il fallait se méfier des orientation de certains membres (allez sans jeu de mot hein, du tout) du forum.

 

Un petit "exo" pour voir si j'ai bien pigé l'idée, et qui m'aidera certainement à comprendre un peu plus ce que je fais par la suite :

 

Rien n’empêcherais de le faire avec une 27C801 au final ? (Hormis une redirection, j'y viens).

 

Au niveau des redirections à faire sur la 801 (corrigez moi si je me trompe):

 

-A19 de la 801 (pin1) soit sur GND donc 0 pour lire les premiers 512kB de l'eprom ou sur le 5V donc 1 pour lire les 512kB finaux de l'eprom ?

(Pour X-cAlibur, j'ai bien mis B en majuscule car d'après ce que j'ai vu b = bit et B = Byte = 8 bits = 1 octet, je me suis pas planté? J'y avais vu y'a un moment mais ça m'était sorti de la tête, j'ai préféré revérifier.). Il faudra bien entendu programmer correctement selon le câblage choisi.

 

Que se passe t'il réellement si on laisse A19 en l'air? Il me semble que j'avais rencontré un soucis de ce type quand j'avais fais mon vieux Chrono Trigger avec la soupe de fils, une ou deux pattes en l'air et ça bootait pas, on m'avait dit de les mettre sur le GND et miracle... Sans bien évidemment connaître l'origine réelle du problème, c'est dommage.

 

-Et il faudrait bien entendu programmer le fichier correctement.

Donc dans la config actuelle faire 1 fichier de 1MB en 4 parties de 256kB avec si par exemple A19 sur 5V avec dans l'ordre :

3*256kB de vide puis les derniers 256kB contenant le "code" originel.

Ou même 4*le code original de 256kB...

 

-Et pour le VPP, qui est l'emplacement 1 de la maskrom sur la carte bah... On programme pas donc c'est pas gênant non?

 

Merci d'avance pour vos réponses / corrections qui m'aident beaucoup :smile:.

Share this post


Link to post
Share on other sites

Alors je suis en forêt avec mon chien donc je réponds vite fait à la partie me concernant.

Donc oui tu as bien écrit 4MB mais ce n'est pas là que tu t'es planté.

Dans le post initial tu parles de 256kb,remolace par ko et tu comprendras le calcul de toi même.

Pour ce qui est de la patte en l'air, ça veut pas dire patte à gnd mais patte a un état inconnu.

Mieux vaut donc éviter, et c'est pas dieu qui me contredira :D

 

Le reste je laisse les potes répondre, sinon le pitbull va s'enfiler un bichon.

Share this post


Link to post
Share on other sites

Salut à tous,

 

un truc auquel je viens de penser,

 

Lorsque j'ai lu le contenu de la maskrom CHR0, je retrouve bien le code identique à la rom que j'ai a programmer,

 

Cependant le code se situe au début du fichier de 512ko et ensuite il y a du vide dans le reste du fichier,

 

J'ai l'impression que ça ne correspond pas avec ce qu'on a mentionné plus haut ou j'ai loupé un truc,

 

Pourquoi le code n'est pas à la fin du fichier et le vide pas au début?

 

Cela dit j'ai deux 27c040 en ma possession actuellement, je vais lui programmer comme vous me l'avez dit, c'est à dire en doublant le fichier de 256ko...

 

Merci d'avance :-),

 

A+,

 

Bool

Share this post


Link to post
Share on other sites

Pour le remplacement j'ai bien compris,

Ce que je comprends pas, c'est pourquoi dans la maskrom le code ne se situe pas dans la partie haute alors qu'A18 est à l'etat haut sur la carte...

C'est sûr qu'en doublant ça marchera...

Ou alors mon collègue se trompe dans les informations qu'il m'a donné !

Share this post


Link to post
Share on other sites

je me suis basé sur ton 1er post, si ton pote est sur que c'est comme expliqué alors le A18 est relié au VCC et donc force les datas sur la 2ème partie de l'eprom.
Mais ca c'est forcément si c'est bien ca ^^
Sinon les datas démarrent bien à l'adresse 0 si A18 n'est pas forcé (ou mis au gnd).

Share this post


Link to post
Share on other sites

Ok, il vérifiera sur la carte, donc la théorie est bonne, c'est tout ce qui m'intéressait, c'est la pratique qui est foireuse là ^^. Dans tous les cas ça fonctionnera avec le fichier doublé...

Merci encore, je vous tiens au courant dès qu'on aura mit les eproms de remplacement sur la carte !

Share this post


Link to post
Share on other sites

Salut à tous,

 

La programmation s'est bien passée, mon pote à testé et ça fonctionne, les glitchs présents avant ne sont plus, bien qu'il en reste un  sur l'écran de victoire mais c'est autre chose

 

Merci encore à tous pour m'avoir aidé à mener à bien ce dépannage !

Share this post


Link to post
Share on other sites

×
×
  • Create New...